System Requirements

Scribe Create – System Requirements

Operating System and Software

  • Microsoft Windows:
    • Windows Vista or higher.
    • Windows 8 compatible in PC mode only. Metro mode is not compatible.
  • Apple:
    • Mountain Lion or higher.
    • NOTE: Safari 6.0 is NOT compatible due to a known issue with this browser. If you have Safari 6.0 on your Mac, please use Firefox until
      this issue is resolved.
  • Mobile:
    • Scribe Mobile is only available on the Apple iOS system
      • Must have iPhone 4S, iPad 2, or iPod 5th generation or later
      • Must be running iOS 8 or later
  • Up-to-date patches for all software
  • A PDF reader to preview and print transcriptions

Web browser compatibility

  • The latest versions of Google Chrome, Mozilla Firefox, OSX Safari are supported
  • Microsoft Internet Explorer 9 or higher.
  • Microsoft Edge support is still in beta

Connectivity

  • Cable, DSL or T1 Equivalent
  • Dial-up may function in an emergency but is not recommended for normal operations